XHC-WHB04B-6 LinuxCNC not working

More
28 Sep 2020 18:16 #184193 by Uthayne
Thanks Romeo, I'm trying this fix out. I reverted back on the hal.cc changes I just made.

If I'm following correctly,
net pdnt.mode.is-manual halui.mode.is-manual whb.halui.mode.is-manual
gets changed to
net pdnt.mode.is-manual whb.halui.mode.is-teleop
and
net pdnt.mode.teleop whb.halui.mode.teleop halui.mode.teleop
gets commented out?

If so, I just tried it and it has the same jerkiness.

Please Log in or Create an account to join the conversation.

More
28 Sep 2020 18:19 #184194 by romeofox
That's what it was meant to be.
I tested my handwheel with LinuxCNC 2.8 and 2.9. Both worked.

Please Log in or Create an account to join the conversation.

More
28 Sep 2020 18:58 - 28 Sep 2020 19:03 #184200 by Uthayne
Would you mind sharing you .hal file? I either keep getting something wrong or it is not working for me.

Edit: changed
net pdnt.mode.is-manual  halui.mode.is-manual  whb.halui.mode.is-manual
to add
whb.halui.mode.is-teleop
(commented this out on
net pdnt.mode.is-teleop halui.mode.is-teleop  #whb.halui.mode.is-teleop
)

and its working now. Strange. I made no other edits.

Full hal file is attached.
Attachments:
Last edit: 28 Sep 2020 19:03 by Uthayne.

Please Log in or Create an account to join the conversation.

More
28 Sep 2020 20:58 - 28 Sep 2020 20:59 #184213 by tommylight

I solved my handwheel problem with a solution from the german cnc-aus-holz.at forum:

I see some angry Austrians coming your way ! :) :) :)
Last edit: 28 Sep 2020 20:59 by tommylight. Reason: typo
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

Time to create page: 0.121 seconds
Powered by Kunena Forum