Installing LinuxCNC 2.9 or Master on Linux Mint 21

More
05 Nov 2023 10:18 - 05 Nov 2023 10:20 #284604 by alangibson
Hello all,

I trying to compile the current LinuxCNC 2.9 branch on Linux Mint 21 with non-realtime kernel just to experiment with component development. According to the docs, the following should work. Has anyone encountered this error before?

$ ./autogen.sh
$ ./configure --with-realtime=uspace --disable-gtk2
[snip]
$ make
Makefile:121: *** Makefile.inc must specify RTPREFIX and other variables.  Stop.

My system is currently

$ uname -a
Linux oxcart 6.2.0-33-generic #33~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Sep  7 10:33:52 UTC 2 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/issue
Linux Mint 21.1 Vera \n \l
Last edit: 05 Nov 2023 10:20 by alangibson.

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 10:36 #284605 by Aciera
Do you actually need the option --disable-gtk2?

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 11:11 #284608 by rodw
I wonder if it is possible to install the new 2.9.1 deb file on Mint from here?
www.linuxcnc.org/dists/bookworm/2.9-rt/
Might be a shortcut

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 11:37 #284610 by alangibson
Same result without that flag I'm afraid

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 11:46 #284611 by alangibson
It's pretty close to working actually:
alangibson@oxcart:~/dev/plasma/linuxcnc$ sudo gdebi linuxcnc_2.9.1_amd64.deb 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libboost-python1.74.0 (>= 1.74.0+ds1)

alangibson@oxcart:~/dev/plasma/linuxcnc$ sudo apt install libboost-python1.74.0
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libboost-python1.74.0 is already the newest version (1.74.0-14ubuntu3).
libboost-python1.74.0 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

I need to look into how to force it to think those two version or equivalent, or just ignore the dependency.

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 12:26 #284614 by alangibson
On second thought, I was being too optimistic. Lack of boost for Python 3.11 will be a problem.
alangibson@oxcart:~/dev/plasma/linuxcnc$ sudo dpkg -i ./linuxcnc_2.9.1_amd64.deb 
Selecting previously unselected package linuxcnc.
(Reading database ... 603625 files and directories currently installed.)
Preparing to unpack ./linuxcnc_2.9.1_amd64.deb ...
Unpacking linuxcnc (1:2.9.1) ...
dpkg: dependency problems prevent configuration of linuxcnc:
 linuxcnc depends on libboost-python1.74.0 (>= 1.74.0+ds1); however:
  Version of libboost-python1.74.0 on system is 1.74.0-14ubuntu3.
 linuxcnc depends on libboost-python1.74.0-py311; however:
  Package libboost-python1.74.0-py311 is not installed.
 linuxcnc depends on libpython3.11 (>= 3.11.0); however:
  Package libpython3.11 is not installed.
 linuxcnc depends on python3-opengl; however:
  Package python3-opengl is not installed.
 linuxcnc depends on libgtksourceview-3.0-dev; however:
  Package libgtksourceview-3.0-dev is not installed.
 linuxcnc depends on tclreadline; however:
  Package tclreadline is not installed.
 linuxcnc depends on python3-pyqt5.qsci; however:
  Package python3-pyqt5.qsci is not installed.
 linuxcnc depends on python3-pyqt5.qtopengl; however:
  Package python3-pyqt5.qtopengl is not installed.
 linuxcnc depends on python3-opencv; however:
  Package python3-opencv is not installed.
 linuxcnc depends on python3-espeak; however:
  Package python3-espeak is not installed.
 linuxcnc depends on python3-dbus.mainloop.pyqt5; however:
  Package python3-dbus.mainloop.pyqt5 is not installed.
 linuxcnc depends on python3-pyqt5.qtwebengine | python3-pyqt5.qtwebkit; however:
  Package python3-pyqt5.qtwebengine is not installed.
  Package python3-pyqt5.qtwebkit is not installed.
 linuxcnc depends on espeak-ng; however:
  Package espeak-ng is not installed.
 linuxcnc depends on espeak; however:
  Package espeak is not installed.
 linuxcnc depends on python3-poppler-qt5; however:
  Package python3-poppler-qt5 is not installed.

dpkg: error processing package linuxcnc (--install):

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 13:48 #284620 by alangibson
I settled on just running it in a Docker container for now since all I really need is halcompile for the moment
docker pull debian:bookworm
docker run -it --name=linuxcnc -v $PWD:/linuxcnc debian:bookworm bash
apt update
apt install -y curl
curl -O https://www.linuxcnc.org/dists/bookworm/2.9-uspace/binary-amd64/linuxcnc-uspace_2.9.1_amd64.deb
curl -O https://www.linuxcnc.org/dists/bookworm/2.9-uspace/binary-amd64/linuxcnc-uspace-dev_2.9.1_amd64.deb
curl -O https://www.linuxcnc.org/dists/bookworm/2.9-uspace/binary-amd64/linuxcnc-uspace-dbgsym_2.9.1_amd64.deb
dpkg -i linuxcnc-uspace_2.9.1_amd64.deb linuxcnc-uspace-dev_2.9.1_amd64.deb linuxcnc-uspace-dbgsym_2.9.1_amd64.deb
apt --fix-broken -y install

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 21:12 #284663 by cmorley
I don't think you need --with-realtime.

I'm using mint 21.2 for development - I don't remember doing anything unusual.

Please Log in or Create an account to join the conversation.

Time to create page: 0.230 seconds
Powered by Kunena Forum