QtPlasmaC release.

More
16 Jul 2021 00:55 #214966 by tommylight
Replied by tommylight on topic QtPlasmaC release.
State pins sometimes at 0, still not moving.
It stops when retracting from the last cut, as you noticed.
BTW, this is on the second PC, both fresh installs.

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 01:22 - 16 Jul 2021 01:55 #214972 by phillc54
Replied by phillc54 on topic QtPlasmaC release.
Thanks Tommy. Could you check the value of the pin plasmac.resolution please.

Edit: Does the Z axis make it back up to where it should or does it stop part way.
Last edit: 16 Jul 2021 01:55 by phillc54.

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 04:15 #214986 by phillc54
Replied by phillc54 on topic QtPlasmaC release.
I pushed a change to the resolution for Z height comparisons so hopefully this will help.

If it happens again could you check the following pins in addition to the previous ones.
axis.z.eoffset
axis.z.eoffset-counts
​​​​​​​axis.z.eoffset-scale
motion.feed-hold
motion.feed-inhibit
 

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 11:48 #215019 by snowgoer540
Replied by snowgoer540 on topic QtPlasmaC release.

Went back to PlasmaC, it worked for over an hour without issues.
Now i can say it out loud, i hate anything QT, just to much cr@p under the pretty looks.

 

Tommy, is it possible for you to post  the backup of your QtPlasmaC config?  

Since we're both saying things out loud, I wonder if this issue might be self-caused by doing different things with your configs that other people don't do.  One example is  manually setting pins that are not intended to be set manually such as:
plasmac.thc-feed-rate

As Phill pointed out, PlasmaC and QtPlasmaC use the same component, but I suspect you use different configs for your PlasmaC and QtPlasmaC and I would almost bet money that PlasmaC config doesnt have the same pins manually set (such as plasmac.thc-feed-rate).  

Of course there's also the possibility it's just a bug you've run into, but the comment that it doesnt do it with PlasmaC makes me wonder...

Anyways, bonus points if you posted both configs I suppose :)

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 11:49 #215022 by snowgoer540
Replied by snowgoer540 on topic QtPlasmaC release.
I cant edit the post because of this editor, but if you didnt want to post the config here, one other option would be emailing to Phill or myself, or both lol
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 12:31 #215038 by tommylight
Replied by tommylight on topic QtPlasmaC release.
Will try to go there today, but no promises, it is 12Km far one way, in a vilage that has power issues.
I will also get the configs as i keep saving them after each change, and upload them here.
I have no issues with uploading stuff here, i do that for everything i think remotely might help others. :)
I just checked the pictures again, the Z postion is different in all of them, so as usuall Phill is onto something.
Also i do manually edit a lot of stuff, it is much easier for me, so this might again end up as me shooting both of my feet at the same time! :)

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 12:34 #215039 by tommylight
Replied by tommylight on topic QtPlasmaC release.
Sorry for posting again but avoiding using the editor.
This also happens on both of my machines, rarely, but not using them lately.
Need to cut something today, so who knows ...
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 12:36 #215040 by snowgoer540
Replied by snowgoer540 on topic QtPlasmaC release.
All sounds good!  

Actually, I just had an epiphany over here.  Generally I've seen you suggest to set "plasmac.thc-feed-rate" at 1000 for other folks. 

I always think in terms of inches per minute, so to me that seemed really high.  In fact, it seems really small for metric.  I dont know for certain what you manually set it to but it could (probably is) a reason you have said in the past that the THC is MUCH slower than it should be as compared to PlasmaC.  

One suggestion I have is to take out the manual setting of thc-feed-rate from your config, then verify with halmeter that it gets set automagically.  I bet it's MUCH higher than 1000.  

I think some of this may be trickle-down from when you had to set it manually because it was missing from the code on accident.  But now manually setting it is doing you more harm than good.  I want to point out, it was SUPER useful at the time for helping us find the issue :)
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 12:39 #215041 by tommylight
Replied by tommylight on topic QtPlasmaC release.
New configs are in short order ...
I will try to refrain from manual editing ... try! :)

Please Log in or Create an account to join the conversation.

More
16 Jul 2021 12:42 #215042 by snowgoer540
Replied by snowgoer540 on topic QtPlasmaC release.
Haha, sounds good, you're always so willing to help on this forum, it's nice to be able to give you a hand once in a while as well.  Especially given how much you've contributed to this project ...

Hope the cutting goes well today, looking forward to hearing your results.  
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.098 seconds
Powered by Kunena Forum