Z axis

More
10 May 2020 21:04 #167302 by motal2004
Replied by motal2004 on topic Z axis
With a little help, I figure out that the “home switch location” is the max my z axis can travel up, Away from slats. Thus “home switch location” is where You would want the z axis to move to when once it find its home/max limit.
So I my case the “positive and negative travel” boxes where throwing me off.
Attachments:
The following user(s) said Thank You: Plasmaguy

Please Log in or Create an account to join the conversation.

More
11 May 2020 01:07 #167317 by phillc54
Replied by phillc54 on topic Z axis
Homing can take a while to get your head around, this gives a fairly good description.

linuxcnc.org/docs/2.8/html/config/ini-homing.html
The following user(s) said Thank You: Plasmaguy

Please Log in or Create an account to join the conversation.

More
11 May 2020 07:55 - 11 May 2020 07:55 #167339 by tommylight
Replied by tommylight on topic Z axis
There is a catch to homing in this case, the home and home offset are tricky to get correctly, i had to set home at 160mm and offset at 165 for it to properly home. Total travel is 170mm plus 10 for the float.
And i have the min set at -10.
Last edit: 11 May 2020 07:55 by tommylight.
The following user(s) said Thank You: Plasmaguy

Please Log in or Create an account to join the conversation.

More
12 May 2020 00:20 #167442 by motal2004
Replied by motal2004 on topic Z axis
So next is the Mesa thcad-10 set up.
Do I really just need to set up the following 3 line in my machine hal file?

setp hm2_7i96.0.encoder.00.scale -1
setp hm2_7i96.0.encoder.00.filter 1
setp hm2_7i96.0.encoder.00.counter-mode 1
My current mode is set to 0 for arc voltage signal
And if so once I plug in the numbers that I calculated for voltage scale and offset what should voltage be reading on the screen just resting?

Please Log in or Create an account to join the conversation.

More
12 May 2020 00:24 #167443 by phillc54
Replied by phillc54 on topic Z axis
If you have a 7i96 then yes, you need those settings in a Hal file.

You should read 0v at rest.
The following user(s) said Thank You: Plasmaguy

Please Log in or Create an account to join the conversation.

More
13 May 2020 00:44 #167584 by motal2004
Replied by motal2004 on topic Z axis
need some more help guys,

mesa thcad-10
at this time i have my mode set to 0 . its blow-back style plasma machine the primeweld cut 60.
its connected to the 50/1 divider.
i calculated the offset & scale. scale 0.01985851 & offset 3668.7500 .
i plug these number in and i get a negative reading of 73 volts. i change my scale to - 0.01985851 and i get a positive 73 volt reading on the screen. so I set the scale # to 0 and it screen shows 0 V , doesn't move from there. i did a test cut and got a reading from the thcad-10 card of 2.245 on my volt meter.
Hoping its something in my hal files. i attached some files check them out.
Attachments:

Please Log in or Create an account to join the conversation.

More
13 May 2020 01:01 #167585 by phillc54
Replied by phillc54 on topic Z axis
A scale of 0 will give 0v out.

Maybe the 50:1 is not accurate. What are the numbers on your THCAD?

Please Log in or Create an account to join the conversation.

More
13 May 2020 01:06 #167587 by motal2004
Replied by motal2004 on topic Z axis
0V is 117.4 KHz
10V is 923.1 KHz

Please Log in or Create an account to join the conversation.

More
13 May 2020 01:10 #167588 by phillc54
Replied by phillc54 on topic Z axis
Well your numbers are spot on.

You didn't add any external resistance?

Please Log in or Create an account to join the conversation.

More
13 May 2020 01:11 #167589 by motal2004
Replied by motal2004 on topic Z axis
Nope, no external resistors.

Please Log in or Create an account to join the conversation.

Time to create page: 0.115 seconds
Powered by Kunena Forum