gladevcp catalog, and other questions

More
14 Jan 2023 11:45 - 14 Jan 2023 11:47 #261926 by JetForMe
After a fair bit of pain getting Glade 3.8 installed so I can edit GladeVCP plugins (I don't remember having this much trouble on my actual machine, but on this uspace simulator, it was a lot of work), it's running into an issue finding the gladvcp catalog:

Failed to load /home/rmann/linuxcnc/configs/sim/axis/gladevcp/manual-example.ui.
The following required catalogs are unavailable: gladevcp"


I've been searching through the sources, but I can't find anything that looks like a catalog file.

Despite running sudo make install after building glade3.8, it didn't work to execute it from there. It does work to execute it from my local source dir. Given that, where should I put the catalog file(s) once I find them?

Also, is there a difference between .ui and .glade files?
Last edit: 14 Jan 2023 11:47 by JetForMe.

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 12:56 #261938 by HansU

Please Log in or Create an account to join the conversation.

More
15 Jan 2023 00:42 #262001 by JetForMe
Alas, I'm on aarch64 (Debian 11 on ARM, my M1 Mac). I tried copying the lib/python/gladvcp contents to `pkg-config --variable=catalogdir gladeui-1.0` (/usr/local/share/glade3/catalogs), but it still can't find the catalog. I don't see anything in that directory that looks like a "gladvcp" catalog.

Please Log in or Create an account to join the conversation.

More
15 Jan 2023 01:42 #262004 by JetForMe
Actually, it's a little better. It no longer gives me the error about not finding the gladevcp catalog, but things still don't show up properly. Now it can't find the 'gladepython', and I'm not sure where to find that.
(glade-3:491771): GladeUI-CRITICAL **: 17:11:00.098: Unable to load module 'gladepython' from any search paths
GladeUI-Message: 17:11:00.195: 3 missing displayable value for GtkCellRendererText::underline
(glade-3:491771): GladeUI-CRITICAL **: 17:11:00.202: Unable to load module 'gladepython' from any search paths
(glade-3:491771): GladeUI-WARNING **: 17:11:00.202: Failed to load external library 'gladepython'
(glade-3:491771): GladeUI-WARNING **: 17:11:00.202: We could not find the symbol "h_al__hide_table_get_type"
(glade-3:491771): GladeUI-WARNING **: 17:11:00.202: Could not get the type from "HAL_HideTable"
(glade-3:491771): GladeUI-WARNING **: 17:11:00.202: Failed to load the GType for 'HAL_HideTable'
(glade-3:491771): GladeUI-WARNING **: 17:11:00.202: We could not find the symbol "h_al__hbox_get_type"
 

Please Log in or Create an account to join the conversation.

More
15 Jan 2023 01:53 #262005 by JetForMe
I'm also having trouble with gtksourceview. I've got the catalog there, but I think I have v3 & v4 installed, not v2. Gonna try to find sources for that.

Please Log in or Create an account to join the conversation.

More
15 Jan 2023 02:03 #262006 by JetForMe
Aaaand, that was a colossal fail. The gtksourceview 2.91.9 (latest v2) configure script can't figure out the target tuple, so I gave it some help. Then it tried to compile source that fails because my system has GTK+3 headers installed.

Please Log in or Create an account to join the conversation.

More
15 Jan 2023 07:16 #262016 by HansU
As you was talking about Glade 3.8 I was assuming you would like to have the catalogs for LinuxCNC 2.8 / Gtk2.
For LinuxCNC 2.9 you need Glade 3.22.
 

Please Log in or Create an account to join the conversation.

More
15 Jan 2023 07:47 #262018 by JetForMe
Oh really? That’s great! But what I understand is that v3.8 was the last one that could work with gtk2, and it seemed like Axis and VCP still used GTK+2. If that’s not the case I need to amend my other post.

Please Log in or Create an account to join the conversation.

More
15 Jan 2023 08:22 #262020 by HansU

But what I understand is that v3.8 was the last one that could work with gtk2, and it seemed like Axis and VCP still used GTK+2. If that’s not the case I need to amend my other post.

That's correct if you are talking about the latest released version, 2.8.
But 2.9 is using Python3/Gtk3 and will be released soon.

Please Log in or Create an account to join the conversation.

More
16 Jan 2023 01:49 - 16 Jan 2023 02:04 #262082 by JetForMe
When I look at configs/sim/axis/gladevcp/manual-example.ui, it shows at the top

<?xml version="1.0"?>
<interface>
<!-- interface-requires gladevcp 0.0 -->
<requires lib="gtk+" version="2.16"/>
...


Isn't version 2.16 GTK+2, which would need Glade 3.8 (or earlier) to examine?

Also, can I use Glade 3.40?
Last edit: 16 Jan 2023 02:04 by JetForMe.

Please Log in or Create an account to join the conversation.

Moderators: mhaberlerHansU
Time to create page: 0.198 seconds
Powered by Kunena Forum