RPI4 Raspbian 64 bit & LinuxCNC

More
07 Sep 2021 04:24 #219812 by jnp1968
Hi Aaroncnc
Actually that was my bad, didn't look long (or hard) enough for the right info.
I just found this documentation explaining how to do it, and got way better results. Now I'm just worried about the fan not starting, so will set up CPU temperature monitoring and let it run to get a feeling about how it's doing.

Got this case with build in heatsink and fan, just need to be sure that the fan is actually starting up under linuxcnc.
Thanks for your reply :)
 

Please Log in or Create an account to join the conversation.

More
07 Sep 2021 12:26 #219846 by andypugh

This looks to me like the python-gtksourceview2 module is missing. 

For armhf it is available from the LinuxCNC repository
www.linuxcnc.org/dists/buster/base/binary-armhf/

However LinuxCNC doesn't have any files for arm-64. 

If we decide to start offering a 64 bit image then that would need to be added. (not difficult) 
 

Please Log in or Create an account to join the conversation.

More
19 Oct 2021 12:50 #223555 by BigJohnT
Just trying this on my Rpi4 and the clone line seems to be off

john@raspberrypi:~ $ git clone github.com/LinuxCNC/linuxcnc.git emc
fatal: repository 'github.com/LinuxCNC/linuxcnc.git' does not exist

git clone github.com/LinuxCNC/linuxcnc.git emc

JT

Please Log in or Create an account to join the conversation.

More
19 Oct 2021 12:51 #223556 by BigJohnT
One more thing

john@raspberrypi:~/emc $ debian/configure uspace
uspace is accepted for compatibility, but ignored
successfully configured for 'uspace-Debian-10'..

JT

Please Log in or Create an account to join the conversation.

More
19 Oct 2021 16:14 #223572 by BigJohnT
My latency was quite a bit worse and unusable I think.
 
JT
Attachments:

Please Log in or Create an account to join the conversation.

More
19 Oct 2021 23:28 - 19 Oct 2021 23:30 #223604 by cakeslob
How is it with isolcpus 1,2,3?
Last edit: 19 Oct 2021 23:30 by cakeslob.

Please Log in or Create an account to join the conversation.

More
20 Oct 2021 00:38 #223608 by tommylight
I have seen worse, and worked quite reliably with Mesa 7i92.
Attach a Mesa board to it, leave it on for a day or two and do stuff occasionally see if it drops the link.

Please Log in or Create an account to join the conversation.

More
20 Oct 2021 02:22 #223618 by rodw

I have seen worse, and worked quite reliably with Mesa 7i92.
Attach a Mesa board to it, leave it on for a day or two and do stuff occasionally see if it drops the link.

I also think this is fine for a Mesa card. I don't know if it will work on a PI but isolcpus=1,2,3 idle=poll  made a significant difference on my J1900

Please Log in or Create an account to join the conversation.

More
20 Oct 2021 11:17 #223653 by BigJohnT
I'm going to try with a 32 bit raspi os. This is just for testing my Rpi GPIO tool and figuring out the man page for hal_pi_gpio component.

JT

Please Log in or Create an account to join the conversation.

More
23 Oct 2021 05:42 #223974 by elovalvo
But have you tried this newer version of the 64-bit Raspbian OS with Preempt-RT?

forum.linuxcnc.org/9-installing-linuxcnc...blem?start=90#217552

Please Log in or Create an account to join the conversation.

Time to create page: 0.463 seconds
Powered by Kunena Forum