RPI4 Raspbian 64 bit & LinuxCNC

More
07 Apr 2022 17:15 - 07 Apr 2022 19:03 #239561 by snakeoil
I feel like a moron but what is the default password for the elovalvo images? Edit: I am a moron after all it's just raspberry. I was booted in to some image running LinuxCNC on Ubuntu and OpenBox. No idea what it was. Days between being able to test, and lots of SD cards laying around in the sawdust.... 
Last edit: 07 Apr 2022 19:03 by snakeoil. Reason: Answered me own q

Please Log in or Create an account to join the conversation.

More
11 Jun 2022 18:54 #244949 by wasausky
Please modify the hal_pin_gpio.c and cpuinfo.c components for the new revision of raspberry pi 1.5 which is not registered.

I received several but they can't open the component

thanks for your help.
The following user(s) said Thank You: elovalvo

Please Log in or Create an account to join the conversation.

More
15 Jun 2022 10:18 #245175 by andypugh
We are working on a fix and there should be a new version (on the buildbot) in the next few days.
The following user(s) said Thank You: elovalvo, rdtsc

Please Log in or Create an account to join the conversation.

More
16 Jun 2022 16:31 #245275 by andypugh
When 55a548ea3948... in 2.8 at buildbot.linuxcnc.org/buildbot/grid is finished then there should be an updated version of 2.8 available from buildbot.linuxcnc.org/ either through apt/synaptic as described there, or by manually installing the .deb from buildbot.linuxcnc.org/dists/
The following user(s) said Thank You: elovalvo

Please Log in or Create an account to join the conversation.

More
03 Jul 2022 23:38 #246548 by euridium
hello, thanks for this detail. took me ages to figure out why Linuxcnc won't launch.

would it be possible for someone to recompile the hal_pi_gpio double step version from member tjtr33 please?
forum.linuxcnc.org/18-computer/36879-ras...-pi-4-mmap?start=480

(are there any plans to integrate this version into mainline Linuxcnc?)

if possible I'm trying to get with latest 2.8.2? I have a pi4 revision 1.5 and I am unable to use any currently compiled double step. I have tried to recompile myself but even setting up the compile environment is beyond me!
I am running debian buster at present but happy to move to what ever distro works for pi4 rev1.5 with double step.

I'd be really grateful.
thanks.

Please Log in or Create an account to join the conversation.

More
04 Jul 2022 23:53 #246614 by andypugh
I have asked the author if he intended his changes to be incorporated in mainline LinuxCNC.

But a the moment I am afraid that compiling it yourself is the only way to get it on your Pi.

Please Log in or Create an account to join the conversation.

More
15 Aug 2022 12:51 #249779 by virencq
I have managed to build master .deb.
After installation Gmoccapy shows more deps requirements (Opengl, libgtksource, namespace).
After lot of deps package I manage to run Gmoccapy.
But mine version Gmoccapy has weared DRO, big plot area and if I check full screen. Screen doesn't fit in 15" display.
What i have done wrong.

Please Log in or Create an account to join the conversation.

More
04 Oct 2022 07:18 #253421 by virencq
please guide me I would also like to install python 3.7.
sudo apt install python 3.7
not working

Please Log in or Create an account to join the conversation.

More
04 Oct 2022 21:42 - 04 Oct 2022 21:43 #253472 by andypugh
sudo apt-cache search python3

Gives

...
libpython3.7-testsuite - Testsuite for the Python standard library (v3.7)
python3.7 - Interactive high-level object-oriented language (version 3.7)
python3.7-dbg - Debug Build of the Python Interpreter (version 3.7)
...

So
sudo apt-get install python3.7
Last edit: 04 Oct 2022 21:43 by andypugh.

Please Log in or Create an account to join the conversation.

More
06 Oct 2022 16:08 - 06 Oct 2022 16:26 #253623 by elovalvo
As a new version of both RaspiOS is available
(www.raspberrypi.com/software/operating-systems/)
Release date: September 22nd 2022
System: 64-bit
Kernel version: 5.15
Debian version: 11 (bullseye)

that of the PREEMPT_RT patch
github.com/kdoren/linux/releases
Raspberry Pi realtime Kernel (5.15.65-rt49)

similarly to what has been done in the past
forum.linuxcnc.org/9-installing-linuxcnc...cnc?start=130#238020

I have prepared the microSD image of this installation
Linux raspberrypi 5.15.65-rt49-v8+ #1 SMP PREEMPT_RT Tue Sep 6 18:12:35 BST 2022 aarch64 GNU/Linux

available at this link
linucnc-2.9.0pre-bullseye_arm64rt.zip
user: linuxcnc
pwd: cnc

Again, the first tests of operation gave good results.
In particular, these are the graphs obtained on Raspberry Pi 400 Rev 1.1 4GB
through the command
latency-histogram --nobase --sbinsize 1000 --show --servo 35000



Attachments:
Last edit: 06 Oct 2022 16:26 by elovalvo.
The following user(s) said Thank You: phillc54, tommylight, mwiktowy, rdtsc

Please Log in or Create an account to join the conversation.

Time to create page: 0.259 seconds
Powered by Kunena Forum