RPI4 Raspbian 64 bit & LinuxCNC

More
07 May 2021 12:15 #208206 by phillc54
I think you are having copy/paste errors, the link on your post is different to the one BeagleBrainz gave you.

Please Log in or Create an account to join the conversation.

More
07 May 2021 12:25 #208208 by Craig E
Thanks I did not know I needed to copy it as a link that worked!

Please Log in or Create an account to join the conversation.

More
07 May 2021 12:47 #208211 by Craig E
Thanks everyone for all your help and patience.
I now have LinuxCNC on my 64bit RPi4.
One last question and I will leave all alone at least for a while.
Any suggestions on the best place to learn about configuring LinuxCNC?

Please Log in or Create an account to join the conversation.

More
07 May 2021 13:09 #208214 by bevins

Craig E wrote: Thanks everyone for all your help and patience.
I now have LinuxCNC on my 64bit RPi4.
One last question and I will leave all alone at least for a while.
Any suggestions on the best place to learn about configuring LinuxCNC?


Your there.... Dive in....

Please Log in or Create an account to join the conversation.

More
07 May 2021 22:43 #208261 by andypugh

Craig E wrote: Any suggestions on the best place to learn about configuring LinuxCNC?


Well, the docs is the obvious place:

linuxcnc.org/docs/2.8/html/

If you read and retain all of that you will be ahead of me, I go there several times a day.

Certainly read the "INI Config" section, and all the "HAL" section.

And it is worth skimming all the HAL components to get a feel for what is in there.

But it is unlikely that you will understand it all before your cards arrive, so don't expect to.
The following user(s) said Thank You: BeagleBrainz

Please Log in or Create an account to join the conversation.

More
28 May 2021 00:00 - 28 May 2021 17:12 #210479 by Doogie
Just to confirm, I loaded 64bit LinuxCNC 2.9.0pre0( lcnc_2.9.0pre0_rt64a.zip ) to a uSD, installed Remora and my Remora Ender 3 configuration and it works as usual. Except that I noticed all 4GB of RAM is now accessible as opposed to 3GB previously.

I've only run an operational test to validate it at least works as previously on the 32bit 2.8.1 image.
Last edit: 28 May 2021 17:12 by Doogie.
The following user(s) said Thank You: elovalvo

Please Log in or Create an account to join the conversation.

More
28 May 2021 17:17 #210543 by cakeslob

Doogie wrote: Just to confirm, I loaded 64bit LinuxCNC 2.9.0pre0( lcnc_2.9.0pre0_rt64a.zip ) to a uSD, installed Remora and my Remora Ender 3 configuration and it works as usual. Except that I noticed all 4GB of RAM is now accessible as opposed to 3GB previously.

I've only run an operational test to validate it at least works as previously on the 32bit 2.8.1 image.

yeah sounds about right

Please Log in or Create an account to join the conversation.

Time to create page: 0.217 seconds
Powered by Kunena Forum