[SOLVED] Qtpyvcp - error on startup

More
14 Jan 2023 04:24 #261878 by spumco
Replied by spumco on topic Qtpyvcp - error on startup
Edited postgui files and merged what I needed until LCNC loaded without complaining.

Still have the original axes error in terminal, resolution is still wrong in probe basic, and still cant get out of estop or turn the machine on.

Please look at the full-screen capture.  Note that the terminal window and Geany look 'normal' for a 1920x1080 monitor.  Look at the LCNC config window... it's wrong.

Same thign is happening to the PB screens

HTOP attached as well.

 
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 04:35 #261880 by Lcvette
Replied by Lcvette on topic Qtpyvcp - error on startup
post your zipped config file
 
The following user(s) said Thank You: spumco

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 04:43 #261881 by spumco
Replied by spumco on topic Qtpyvcp - error on startup
Keep in mind that the postgui stuff was merged quickly.  Had to rename the not.0 to not.4 and comment out a couple things.
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 04:45 - 14 Jan 2023 04:46 #261882 by rodw
Replied by rodw on topic Qtpyvcp - error on startup

@rodw it does look like it kinda fits albeit a little scrunched in places compared to the 1920x1080 display..

 
YEs you are right but if you go back and look at spumco's screendump, the right side is truncated and it does not extend the full height.

My chromebook on 1092 x 1080:
 
Attachments:
Last edit: 14 Jan 2023 04:46 by rodw.
The following user(s) said Thank You: Lcvette

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 04:50 #261883 by Lcvette
Replied by Lcvette on topic Qtpyvcp - error on startup
not sure why yours is reformatting, did you tweak? looks like all the buttons and widgets are resizing and i locked them from doing so in qtdesigner

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 04:55 #261884 by spumco
Replied by spumco on topic Qtpyvcp - error on startup

not sure why yours is reformatting, did you tweak? looks like all the buttons and widgets are resizing and i locked them from doing so in qtdesigner
 


I haven't touched anything backstage.  And it's not just the qtpyvcp screen, the LCNC config chooser is also distorted.

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 04:59 #261885 by Lcvette
Replied by Lcvette on topic Qtpyvcp - error on startup
this is 2.10? i haven't ever tried 2.10, so you are swimming in the deep end..lol

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 05:01 #261886 by rodw
Replied by rodw on topic Qtpyvcp - error on startup
This is only a 14" monitor so I run it at 1536 x 864 which was my first screen dump
I then changed the resolution to 1980 x 1024 for the second screen dump. the PC is not useable at this resolution as text is too small.
The main thing I noticed was the spindle sliders were wider.
I just wanted to prove a point the error on startup is a non issue

But Spumco's screen is truncated earlier in this thread.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 05:04 #261887 by rodw
Replied by rodw on topic Qtpyvcp - error on startup
There is not really anything much different with 2.10 its just that 2.9 has been hived off pending release.
To build 2.9 be sure to 
git checkout 2.9

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 05:08 #261888 by Lcvette
Replied by Lcvette on topic Qtpyvcp - error on startup
@rod, your screen shot is also broken like his, something is wrong with both of your PB installs it appears, something in the formatting, but what i am not sure. something is breaking the layout format. it should look like my screenshot regardless of how it opens on the screen, but would just extend beyond. so something must be off in 2.10 if both of you are on the same version. do either of you have a 2.9 you can check from a recent script install?

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.337 seconds
Powered by Kunena Forum