qt_dragon_hd - manual tool change and remap

More
24 May 2023 01:40 #272067 by cmorley
Also if you could post your config files...

Please Log in or Create an account to join the conversation.

More
24 May 2023 03:10 #272071 by grey_goat
I'm using a switch type toolsetter.

I switched the polarity of the wiring from the diagram that came with the toolsetter, and now my halmeter for the pin sits at true, turning to false when I press the button. This is progress, it used to do nothing but stay false. It was contributing to my confusion with the halmeter as that was the first time I'd used it and nothing was happening when I pressed the toolsetter.

I think this has resolved my current issue. Stay tuned for tomorrow, when there's something else I can't figure out how to do.

Please Log in or Create an account to join the conversation.

More
24 May 2023 03:18 #272072 by cmorley
you will need to invert the signal now.
probe-input must be normally false - true when tripped.
The following user(s) said Thank You: grey_goat

Please Log in or Create an account to join the conversation.

More
25 May 2023 03:13 #272130 by grey_goat
I inverted the signal. Now when I trigger the toolsetter after completing a tool change I immediately get. "Probe is already tripped when starting G38.2 or G38.3 move"
Attachments:

Please Log in or Create an account to join the conversation.

More
25 May 2023 04:26 #272135 by cmorley
hmm can you confirm again that motion.probe-in is false when the probe is not tripped?

Please Log in or Create an account to join the conversation.

More
25 May 2023 05:12 - 25 May 2023 05:13 #272137 by grey_goat
Can confirm.

My understanding is that the tool was supposed to touch the tool setter, back up, and then touch it again slowly. At the moment a single touch triggers, "the probe is already tripped," when pressed for the first time.
Last edit: 25 May 2023 05:13 by grey_goat.

Please Log in or Create an account to join the conversation.

More
25 May 2023 12:58 #272147 by cmorley
What speeds to you have set for searching/probing?

Please Log in or Create an account to join the conversation.

More
25 May 2023 23:20 #272177 by grey_goat
Search velocity is 40mm/min and probe velocity is 10mm/min

Please Log in or Create an account to join the conversation.

More
26 May 2023 01:09 #272181 by cmorley
Sounds very slow.
On my little test mill I search at 10 ipm and probe at 5 ipm.
That's about 250 and 125 mm/m

I would try bumping up the search speed - try double and see if that has an effect.

Please Log in or Create an account to join the conversation.

More
26 May 2023 01:22 #272182 by grey_goat
I went up to 250 and 100. I had slowed it down from 300 and 10 initially.

Now the error is, "probe tripped in non-probe move."

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.248 seconds
Powered by Kunena Forum