Bridgeport Torq-Cut TC4G Retrofit

More
19 Jan 2021 02:21 #195862 by chopper79
Spindle motor bearings are listed on the motor frame. I have not had to repair the spindle itself yet.

Spindle motor bearings are:

(1) 6308M2ZZAC3P6Q
(1) 6208M2ZZAC3P6Q

Please Log in or Create an account to join the conversation.

More
04 Feb 2021 20:01 - 04 Feb 2021 20:28 #197674 by chopper79
I am in need of some help here.

I am in the beginning stages of testing the LCNC config with the machine before I button up the last of the wiring and give y'all update pictures. The issue I am having is as followed:

1) Can not get any axis to move without a following error. I have tried many different encoder scale values based on the information I can find.

2) The jog velocity never changes when trying to move also. If control is set to 10 IPM the axis just rotates slow before the following error. If I change the jog to 600 IPM the axis rotates at the same slow speed before the following error. Almost like it is not getting a +/- 10v signal.

3) Have an issue with the spindle as well but I will save that one until the axis can move correctly.

The servo motor part number = SGMG-13A2AB which means it has a 8192 pul/rev from what I can tell. Also the ball screw on the machine is a 12mm pitch which should equate out to an encoder scale of ~ 69,358.0 unless my math has failed me which is possible.

I have attached the servo spec sheet and my config files.

If anybody has any ideas on this issue that would be great. Also if it matters the config was setup using PNCconf.
Attachments:
Last edit: 04 Feb 2021 20:28 by chopper79.

Please Log in or Create an account to join the conversation.

More
04 Feb 2021 20:49 - 04 Feb 2021 20:49 #197680 by Todd Zuercher
Have you tuned the PID loops in Linuxcnc? A servo can't work without tuning, and every one is different and requires it's own specific settings for the specific application you are using it in. For example 4 identical motors used for for different axis on the same machine will likely all have different optimal PID settings, because each axis will have different inertia, friction, and possibly scale.

Have you read any servo tuning tutorials.
gnipsel.com/linuxcnc/tuning/servo.html

It also doesn't hurt to read some that are not specific to Linuxcnc.
Last edit: 04 Feb 2021 20:49 by Todd Zuercher.
The following user(s) said Thank You: chopper79

Please Log in or Create an account to join the conversation.

More
05 Feb 2021 01:13 #197697 by chopper79
I have not went into the tuning yet as I am not even able to jog more than 1/8 of a rotation of motor shaft before the following error occurs. I did set my following error to 1.0" and still could not get the machine to jog hardly at all until the following error occurred.

Based on my experience with other retrofits I have never had to adjust the PID to get basic movement. Once basic movement with a large error is achieved then I tune everything in. Either I am lucky or something else is going on with my setup. Here is the current status of lets just go with Y axis

* Axis is stationary when enabled (No runaway or movement of any kind, minus dither of 0.0001")
* When trying to jog axis the motor will move about 1/8 of a rotation and then fault with a following error
* Increased error to 1.0" which allows for maybe 1/2 rotation of motor shaft
* Jog speed set at 10 IPM (slow rotation of motor shaft)
* Jog speed set at 600 IPM (Same slow rotation as 10 IPM)

I have not adjusted any PID items yet. Just seemed odd that there was no basic movement of the machine like the other 8 times I did retrofits. I also have not put a VOM on the +/-10 to see what the voltage is either so I can not report that.

Encoder scale math (Please verify) 8192 p/r x 4 / 12.0mm (Pitch) = 2730.666 x 25.4 = 69358.933 (Sound correct?)

I will double check a couple things tomorrow and see what happens. I may have a feedback signal, output signal, and scale all incorrect which is causing this. I don't know...

Please Log in or Create an account to join the conversation.

More
05 Feb 2021 02:48 #197702 by chopper79
Well... I feel like a complete idiot now.

After doing a bit of thinking about my statement earlier on how it seems that something is up with the +/-10v. I decided to check the wiring..

Y axis works wonderfully now. It helps when you do not have the Aout and Gnd swapped for your analog out. The end was cut off so I made a guess at what was what.

I went with a simplistic approach which was Red wire goes to Aout and Black wire goes to Gnd. It is actually the other way Black goes to Aout and Red goes to Gnd.

Well time to do the X and Z axis and hopefully the 7i77 is not damaged. It should not be even though this mistake can damage it.

Will update more tomorrow..

Please Log in or Create an account to join the conversation.

More
05 Feb 2021 16:55 #197757 by chopper79
Got all X,Y, and Z axis all working (Excluding tuning of the PID)

The spindle issue I mentioned previously is still giving me some grief. Here is what is happening.

* Spindle CW is pressed and the spindle turns on and runs in CCW at -18rpm. (VFD shows FWD)
* Spindle speed increase is pressed (1 click) and spindle changes direction and rotates CW at 94 rpm (VFD shows FWD)
* When I stop the spindle the spindle stops
* Spindle CCW is pressed the spindle rotates CW at +24 rpm (VFD shows REV)

M3s100 starts spindle CW and rotates at +94rpm (VFD shows FWD)
M4s100 starts spindle CW and rotates at +133 rpm (VFD shows REV)

Not exactly sure what is going on at this moment. Any pointers?

Please Log in or Create an account to join the conversation.

More
05 Feb 2021 21:34 - 07 Feb 2021 21:12 #197780 by chopper79
Ok this is for anyone else who is taking on this adventure with one of these machines that has the 626vm3c drive for the spindle. If you take apart your spindle motor to replace bearings or the internal encoder. You have to set the drive up to account for the removal of the encoder in the motor. I marked it before taking off, but when reassembling I must have been off a little bit.

Parameter C1-11 in the drive changes this so you can match your rpm to the new position of the magnetic encoder after rebuild.

After adjusting this I now have FWD and REV correctly working with a speed feedback that matches both the encoder in the spindle motor and the one on the spindle itself.

First time using one of these spindle drives and rebuilding a spindle motor. Learning something new all the time.

Making progress slowly, but worth the struggles so far.
Last edit: 07 Feb 2021 21:12 by chopper79.

Please Log in or Create an account to join the conversation.

More
07 Feb 2021 21:26 - 16 Feb 2021 23:35 #197957 by chopper79
Well I am messing with the spindle some more and noticed the following:

Press spindle CW button and the spindle enables and a small amount of voltage is being provided causing the spindle to rotate somewhere between 0 and 1 rpm.

I believe that the issue might be coming from my configuration or LCNC. Maybe not though...

I change the VFD to operate from the keypad on the VFD the spindle works perfect. When I change back to operating the VFD via LCNC the spindle has this light rotation. I also removed the analog wiring from the 7i77 and tested. When the CW button is pressed the FWD indicator on the front of the VFD turns on and no rotation is present. Voltage is present on analog outputs on 7i77 still. I took a voltage measurement on the analog terminals and I am getting ~ 0.006vdc of output from the 7i77 with the CW button pressed and no speed command given.

My question is do I need to scale the output somehow, so the small voltage present is no longer present?

This is preventing me from moving forward with the configuration as I do not want to work on other items (Spindle wise) until I can get this issue squared away. That being said any help would be great.
Last edit: 16 Feb 2021 23:35 by chopper79. Reason: Remove picture

Please Log in or Create an account to join the conversation.

More
08 Feb 2021 19:48 - 08 Feb 2021 19:56 #198056 by chopper79
Working on this spindle issue today and can not seem to make any headway.

1) Verified motor connections (Rotation is correct)
2) Verified encoder connections (All are good according to print)
3) Cleared VFD of all settings (Back to factory settings)
4) Verified configuration (Tried 3 known functioning configs and 1 new config)
5) Removed encoder from LCNC (Issue is still present)
6) Verified VFD is functioning from drive keypad/control panel (No issue with rotation)
8) Verified spindle does not move when analog5 is not physically connected to drive analog inputs
9) Verified there is ~ 0.006vdc analog5 outputs when either cw or ccw is pressed with no command input
10) Noticed there is always a 1rpm offset when watching items in hal configuration (Turn spindle on = 1rpm. Turn spindle up to 100rpm and hal shows 101rpm)
11) Tried spindle on analog4 and same issue as on analog5

Still no luck on this as of now. I will update more later as this gets worked through. As always any suggestions are welcome..
Last edit: 08 Feb 2021 19:56 by chopper79.

Please Log in or Create an account to join the conversation.

More
08 Feb 2021 20:10 #198058 by PCW
Had you previously set the spindle speed to 1 with
M3 S1?

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.171 seconds
Powered by Kunena Forum